prod_1c‎ > ‎Заметки 1С: 8.3‎ > ‎

Запуск Регламентного задания (Файловый вариант)

Отправлено 2 июл. 2013 г., 14:12 пользователем Nikolay Nikolaev   [ обновлено 25 июл. 2013 г., 1:44, автор: Nikolay Nikolaev ]
1.Создать обработку ПланировщикЗаданий
2.Код в Модуле Формы

//ДЛЯ ТОГО ЧТОБЫ РАБОТАЛО В ФАЙЛ-СЕРСЕРНОМ ВАРИАНТЕ

//ДАННАЯ ОБРАБОТКА ДОЛЖНА ВИСЕТЬ В ОТКРЫТОМ ПРИЛОЖЕНИИ, В КЛИЕНТ-СЕРВЕРНОМ ЭТА ОБРАБОТКА НЕ НУЖНА

&НаКлиенте
Процедура ОбработкаЗаданий()
   
    #Если ТолстыйКлиентУправляемоеПриложение Тогда
        ВыполнитьОбработкуЗаданий();
    #КонецЕсли          
   
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   
    #Если ТолстыйКлиентУправляемоеПриложение Тогда
        ПодключитьОбработчикОжидания("ОбработкаЗаданий", 15);
    #Иначе
        Предупреждение("Обработка может быть запущена только в толстом клиенте!");
        Закрыть();
    #КонецЕсли   
                  
КонецПроцедуры